Author Topic: Special characters only in 64bit?  (Read 1872 times)

Andreas Mikula

  • Guest
Special characters only in 64bit?
« on: August 29, 2023, 08:49:06 am »
Dear Jan,

I am living in Austria using German as preferred OS language.

On my main laptop with Windows 10 64 bit and latest 1.08 the East European characters (from Radio Slovenija) work as expected.

On my second (much older) laptop with Windows 7 32bit but latest 1.08 as well these characters are not showed. Therefore, I tried to install Windows 10 32bit on it, but they still don't show.

Also the log files are wrong then.

> NINA PUŠLAR,  ZLATKO - V ISKANJU SRECE
instead of
> NINA PUŠLAR,  ZLATKO - V ISKANJU SRECE

Same with

> Več kot radio
gets
> Vec kot radio

Is this a bug in RDSSpy or is Windows 32bit not able to save them? Unfortunately the tiny laptop cannot be installed with Windows 64bit.



The same problem is in Ubuntu 64bit and Wine

For example

http://andimik.bplaced.net/rds/spyfiles/9202_-_2019-12-30_11-11-59.spy
http://andimik.bplaced.net/rds/spyfiles/9202_-_2019-12-30_11-14-16.txt

Jan

  • Hero Member
  • *****
  • Posts: 1080
Re: Special characters only in 64bit?
« Reply #1 on: August 29, 2023, 08:59:28 am »
The RDS Spy is written in old Delphi environment and thus it supports only 8-bit ANSI encoding. This is usually not a problem until you listen to a far station from another country. Special characters may not show properly if they are not included in your local Windows ANSI character set. That set is however switchable in the Windows settings.