Author Topic: Radiotext from NEXGEN automation to BW Broadcast (with Magic RDS 4)  (Read 3062 times)

subyluke

  • Newbie
  • *
  • Posts: 3
Hello, I'm trying to do the easiest thing with your great software.  Simply to dynamically get the Song Title and Artist to the RBDS encoder in our BW Broadcast transmitter.  I've read the help screens, but apparently don't really understand the basics of what I have to do!

I've set up an RDS encoder (Readbest) and it is connected to the BW Broadcast transmitter (via TCP).  I can change the static RT text or read the static RT text using Magic RDS 4.  So far so good!

I have also set up virtual port for it which listens to data sent from the NEXGEN automation system.  It is receiving the song title and artist as it is sent in the RDS Encoder as I can see it on the "overview" screen (with the communications monitor "on").  The song title and artist are even displayed next to the station's call letters on the "overview" screen. 

But it isn't sending this data to the BW Broadcast transmitter's RBDS encoder!

Am I supposed to be using the "External Text Sources"?  Or do I also have to add a "bridge" ?

The software seems wonderful... but I am missing something critical here!

Thanks.

Jan

  • Hero Member
  • *****
  • Posts: 1080
It seems you did everything right. The BW V3 transmitters were known for a bug in their TCP stack implementation. See for example here: https://pira.cz/forum/index.php?topic=689.0

To verify this, please make a test: In the same time the V3 is not showing the text from the automation, try to send some RT manually, using the RDS Content - Radiotext - TEST.  The RT is encoded same way in both cases so I would expect the same result.

subyluke

  • Newbie
  • *
  • Posts: 3
Thank Jan, Using 'RDS Content' and clicking 'Read' it always shows what static text I've entered into the V3 GUI.  Also, if I enter some test text (in Magic RDS 4) then READ it, it always does show the test text!  So it seems like the Magic 4 RDS software does know how to communicate with the V3.

Jan

  • Hero Member
  • *****
  • Posts: 1080
Yes, the communication normally works with the BW TX V3 (with regard to the exception mentioned above).

It seems to be a configuration issue. Well, I think you can discover the cause. In the Communication monitor, you can see the outgoing data. Please make a comparison between data sent after manually pressing the Radiotext - Test button and the data sent by External text tool. Copy&paste both cases to this forum so we can decide.

subyluke

  • Newbie
  • *
  • Posts: 3
Thanks!  I think this will help a lot.  The NEXGEN automation is exporting "RT=Song Title/Artist" when it should be "TEXT=Song Title/Artist"  I will let you know if changing the export string works.  Thanks again.

Jan

  • Hero Member
  • *****
  • Posts: 1080
Thanks, that explains it all. There are two options in such a case:

  • Change the prefix in the NEXGEN from RT= to TEXT=
  • Use External text sources for processing the text

The second case is described in m4vp.pdf, section 'Redirecting to External Text Sources'.

Anyway, I'll add the RT= command to the communication protocol translator, so in next version, the VP will convert it automatically.

Jan

  • Hero Member
  • *****
  • Posts: 1080
It was fixed in current release. Thank you for your time.