Author Topic: Constant Disconnects  (Read 382 times)

Steve Vincent

  • Guest
Constant Disconnects
« on: December 12, 2022, 04:58:45 pm »
Hey Jan,
I'm having an issue with TCP connections. Let me share the setup I have. I use Magic RDS 4 at several locations and most have static IP addresses that makes things go smoothly. However, there is one location that does not. At present, we are only able to use wireless internet service. It has proven to be quite stable but since I don't have a static, I have had to turn things around so to speak. Instead of sending the data from the studio to the site, I had to go from the site back to the studio to get the data. My setup is a Bridge that is using a VP in TCP client mode to go back to the studio and connect to the Magic RDS. This data, when received, is then written to a local file at the site thru the internal channel setting. Then I have an encoder set to Readbest that reads the local file and forewords it on to the transmitter RDS. When I first set this up it worked fine but hours later when I checked on it it had stopped. The studio side showed the symbol for error in the connection but the site side showed that it was still connected yet no data was being received. I restarted the site side and it started working but after so many hours it stops again. Am I doing this right? Is there a better way? Thanks for any help you can provide.

Steve

Jan

  • Hero Member
  • *****
  • Posts: 916
Re: Constant Disconnects
« Reply #1 on: December 12, 2022, 07:47:56 pm »
Dropped TCP connection by the network. In your specific case the client only receives data so it cannot recognize that the TCP connection no longer exists. As the result, the automatic TCP reconnect never occurs.

We will find a solution.

wsof

  • Newbie
  • *
  • Posts: 17
Re: Constant Disconnects
« Reply #2 on: December 13, 2022, 03:46:05 pm »
Thank you!

Steve

wsof

  • Newbie
  • *
  • Posts: 17
Re: Constant Disconnects
« Reply #3 on: January 11, 2023, 02:18:18 pm »
Just dropping in to see if you've made any progress. Thanks again !

Steve

Jan

  • Hero Member
  • *****
  • Posts: 916
Re: Constant Disconnects
« Reply #4 on: January 11, 2023, 03:27:19 pm »
Yes, the TCP Keep-alive mechanism has been successfully implemented to the Virtual Ports. We will release it after making some more tests, probably during tomorrow.