Author Topic: P332 bidirectional communication not working  (Read 1124 times)

Allison

  • Newbie
  • *
  • Posts: 3
P332 bidirectional communication not working
« on: February 28, 2018, 10:31:56 am »
Setting u a new P332. Could not get the RS232/USB port working in the first instance, so used Ethernet. YManaged to get bidirectional comms on web and Magic RDS, so set Station PI, PS, PTY, TP, MS. P332 accepted this and is now transmitting to RDS tuners fine. Then tried to connect Jazler to the RDS (it’s a function within Jazler) but saw there was a port conflict with Jazler defaulting to port 4001 and P332 on Port 23. Tried changing Jazler to Port 23, and it reported a TCP/IP comms error. Changed it back to 4001, reset the P332 to port 4001, whereupon the P332 reported a comms error.
I now can’t get back into the P332 in a browser or in Magic RDS except using the RS232/USB cable and Magic, but it will only allow uni-directional comms. As soon as I tick Bidirectional, it loses comms again. It refuses to communicate using the TCP/IP protocol at all. But, when connected via Ethernet we can ping the IP address
We’ve disconnected the P332 from mains and removed the battery in an unsuccessful effort to force a factory reset. Any ideas, please? Need to re-establish bidirectional comms either using RS232/USB or Ethernet. NB we used a static IP address for the Ethernet connectivity in the first instance.

Jan

  • Hero Member
  • *****
  • Posts: 567
Re: P332 bidirectional communication not working
« Reply #1 on: February 28, 2018, 10:56:23 am »
If you lose the communication over Ethernet due to incorrect network settings, forgotten password or port number etc., there's always a possibility to restore the configuration using the local port (Port 1), i.e. the serial port on the P332.

  • Connect the RDS encoder to the PC using the original cable included. If you use other cable, make sure it's a crossed cable (also called null-modem or laplink).
  • If your PC is not equipped with RS232 port and you're forced to use USB to RS232 adapter, this should be FTDI chip based as this is the only reliable solution.
    Low-cost Chinese adapters based on Prolific chip often exhibit erratic behaviour and we do not guarantee function with these adapters. Usually the Prolific drivers do not support baudrate switching while the port is opened so automatic baudrate detection does not work in the Magic RDS. Look at the P332 display, parameter SPEED, and select that speed manually in the Magic RDS (Options - Preferences). Confirm the Bidirectional communication.
  • Once you establish the connection, select RDS Encoder - Device Setup in the menu and restore the network settings to desired values. Reset the device.

Unchecking the Bidirectional communication checkbox, it may look like the communication is working but this is only due to the fact that no response is received nor expected. Check the cable and wiring.

P.S.: The internal battery is used only for real-time circuit backup. User is not allowed to open the cover. There's nothing to be set.

Allison

  • Newbie
  • *
  • Posts: 3
Re: P332 bidirectional communication not working
« Reply #2 on: February 28, 2018, 12:39:07 pm »
Thanks for prompt reply. We’ve never been able to use the RS232/USB, even with the FTDI drivers. We could only set up using TCP/IP, which was successful. I think we’ve established we’ve got a network issue here which is part of the problem, which we will work on to resolve, but I am still concerned that the RS232 option doesn’t work.
By the way, on Device Setup/Special/Device Reset, will that do a restore to Factory Defaults, like it was out of the box?
By the way, the web browser access is also not working on any network. Putting IP address in any browser simply gives an “address not found” result, regardless of which network one is connected to.

Jan

  • Hero Member
  • *****
  • Posts: 567
Re: P332 bidirectional communication not working
« Reply #3 on: February 28, 2018, 08:54:02 pm »
The RS232 always works, this port cannot be disabled by any way. You can always use it for restore the network settings if they were previously set incorrectly, incl. the internal web server port. The prerequisite however is that you use correct serial cable and select correct serial COM port in the application. Other option, like a button, is not provided on this device.
The P132 may be a better option if you don't want to use the RS232 port.

Allison

  • Newbie
  • *
  • Posts: 3
Re: P332 bidirectional communication not working
« Reply #4 on: March 06, 2018, 01:21:23 pm »
Using the recommended FDTI cable did the trick. Thanks.