Author Topic: Pira Cz 5W FM Transmitter - PLL does not lock  (Read 1954 times)

Vojtěch Bubník

  • Newbie
  • *
  • Posts: 2
Pira Cz 5W FM Transmitter - PLL does not lock
« on: August 08, 2015, 03:15:05 pm »
Hi gang and especially the author of the Pira Cz 5W FM Transmitter.

I am building the transmitter on a two sided PCB made by the toner method. The PLL is clocked by a 6.4MHz crystal. The CPU works, the PLL controls the varactor voltages with a success and to some extent the PLL controls the VFO, so when I increase the frequency on the display, the VFO frequency rises. But the VFO frequency is higher than the displayed frequency by some 4 Mhz and I hear a clicking noise in the radio. I see a similar effect on the scope when inspecting the varactor voltages. In the current state of my transmitter only the VFO is running and no other RF transistor is populated yet. I used the Tesla KB105G varactors as a substitute for the recommended parts. I had to use two KB105 varactors in parallel to achieve high enough capacitance.

I exhausted all the ideas of mine. Any advice will be appreciated.

Thanks, Vojtech

Vojtěch Bubník

  • Newbie
  • *
  • Posts: 2
Re: Pira Cz 5W FM Transmitter - PLL does not lock
« Reply #1 on: August 08, 2015, 04:32:46 pm »
Gang,

I found it! My particular SA5511 PLL chip did not work correctly with the 6.2 MHz crystal. The crystal is indeed out of the PLL chip specification. With a common 3.578 MHz crystal the PLL locks in 30 seconds.

Now I shall to get the proper 3.2 MHz crystal.

Vojtech