Author Topic: New Install - 11001 Socket Error  (Read 2997 times)

square_eyes

  • Newbie
  • *
  • Posts: 8
New Install - 11001 Socket Error
« on: November 26, 2014, 12:32:39 am »
I have Silence Detector working on an old PC. I'm migrating to a new one. On a new install, when sending an email I get...

ERROR: Socket Error # 11001 Host Not Found.

I have allowed Pira CZ through my firewall (also tested with firewall disabled).

I am using "smtp.gmail.com:587" as per here here.

I have also reinstalled the app.

Any ideas?


Jan

  • Hero Member
  • *****
  • Posts: 537
Re: New Install - 1101 Socket Error
« Reply #1 on: November 26, 2014, 08:31:36 am »
Verify that the hostname and the port are correctly written in the field. No spaces in front etc.

square_eyes

  • Newbie
  • *
  • Posts: 8
Re: New Install - 11001 Socket Error
« Reply #2 on: November 26, 2014, 08:33:01 am »
Thanks for the response. Yeah I have checked that. It's verbatim.

Jan

  • Hero Member
  • *****
  • Posts: 537
Re: New Install - 11001 Socket Error
« Reply #3 on: November 26, 2014, 08:42:36 am »
It may be a temporary DNS issue. What about 173.194.65.109:587 ?

square_eyes

  • Newbie
  • *
  • Posts: 8
Re: New Install - 11001 Socket Error
« Reply #4 on: November 26, 2014, 08:56:17 am »
OK, some progress, that gives me "Error 5.5.2 syntax error fk16fm6120140wic.16 gsmtp". But it feels like the request is getting out of my computer anyway at least.

Could it be that my isp is blocking outgoing SMTP? The working machine is at another address.

square_eyes

  • Newbie
  • *
  • Posts: 8
Re: New Install - 11001 Socket Error
« Reply #5 on: November 26, 2014, 09:06:42 am »
OK I fixed it. With the change above, and changing the default '@' in the 'To:' and 'From:' fields to my address, the email got through. Seems the @ character caused issues with the handshake.

Cheers for the help:)

I wonder what the issue is with the DNS?

Jan

  • Hero Member
  • *****
  • Posts: 537
Re: New Install - 11001 Socket Error
« Reply #6 on: November 26, 2014, 09:15:29 am »
OK I fixed it. With the change above, and changing the default '@' in the 'To:' and 'From:' fields to my address, the email got through. Seems the @ character caused issues with the handshake.

Yes, it may be difficult to send an email if you didn't specify the sender and recipient ;)

square_eyes

  • Newbie
  • *
  • Posts: 8
Re: New Install - 11001 Socket Error
« Reply #7 on: November 26, 2014, 09:16:56 am »
Yes but that didn't cause the socket error. It was only default because I reinstalled the Silence Detector to test (that this field was reset to default). When I use Google SMTP DNS I still got the 1101 error.

Edit: Wow, and now smtp.gmail.com:587 is working! Perhaps reinstalling the Silence Detector helped after all. It might be worth nothing that I copied the config over from App Data, from the working machine. It loaded fine so I assumed the profile had migrated correctly.

Jan

  • Hero Member
  • *****
  • Posts: 537
Re: New Install - 11001 Socket Error
« Reply #8 on: November 26, 2014, 10:06:09 am »
There's nothing stored in the configuration file which may cause this error. I think it was simply some temporary DNS issue.