Post reply

Message icon:

Unregistered users must pass a verification:

Please enter the number from the picture above which is showing FM broadcast antenna:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Jan
« on: April 07, 2023, 06:00:05 pm »

Fortunately, this product's origin is the Czech republic, where we frequently use characters like ŠČŘŽÝÁÍÉÓěščřžýáíéóůúťď etc. Thus, the system naturally supports Unicode set and conversions between UTF-8 and EBU Latin set for RDS. There's currently no known issue with this.

The UECP is a binary protocol so the data in the Monitor is showed as hexadecimal numbers.

There is only one checkpoint which is relevant: The communication decoder, which should show the ÅÄÖ correctly, if the source coding matches. All other conversions are made automatically and require no attention from your side.

Some obsolete encoders, however, may be set to a legacy PC 8-bit code page, that may lead in showing of incorrect characters on receivers due to unwanted conversion. Similar way, some obsolete receivers may not be able to show the extended set.
Posted by: Daniel
« on: April 07, 2023, 04:07:03 pm »


I'm having trouble displaying ÅÄÖ characters. Im using the generic UeCP connection. The text is recieved from a txt file on my local computer in UTF-8 encoding. Which from my understanding should be able to display ÅÄÖ characters. For some reason, which I'm not quite sure of, the text is translated to hexadecimal numbers, which can not display any of these characters.

I have tried both unicode converters, none of them seem to have worked. The Basic latin encoding should not contain these characters according to the specification, but the EBU Latin G0 should, which I find a bit strange.

When trying to convert the string from hexadecimal characters to "normal text" the characters ÅÄÖ is translated to hexadecimal value of 20 which is "whitespace".

Could anyone please help me?