Post reply

Message icon:

Unregistered users must pass a verification:

Please enter the number from the picture above which is showing FM broadcast antenna:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Jan
« on: December 08, 2020, 06:40:17 am »

We produced a long story :D
Happy to see it is ok.
Posted by: Nemosity
« on: December 07, 2020, 10:18:51 pm »

The good news is that after making the suggested changes, seems to be working as expected and updating!  The bad news is that the other unit, with the same exact settings, is not updating or displaying the dynamic PS.  I may try and drive to the site this week and reload the firmware again.  Everything on these two units is set exactly the same in the automation and on the P332's themselves, one is working, the other is not.  Getting closer!

**I went over everything, screen by screen starting with my automation config.  I noticed that I was missing the [013] on the setup for WIAB's messages.  They are BOTH working now!  Thank you so very much for your time and attention to this!
Posted by: Jan
« on: December 07, 2020, 08:23:07 pm »

Is the RT+ (Radiotext Plus) something you're interested in? Because if you can define such output template, you may omit the DPS, which is obsolete, and go directly to XCMD. For example:

Code: [Select]
XCMD=<rds><item><dest>7</dest><text><title>[TITLE]</title> by <artist>[ARTIST]</artist> on WLMN IPR NEWS RADIO</text></item></rds>[13]The destination code 7 means Dynamic PS, Radiotext and Radiotext Plus.

Select and copy this text into the template field.

Anyway, there are some other possibilities using old data format:

For Dynamic PS only:
Code: [Select]
DPS1ENQ=[TITLE] by [ARTIST] on WLMN IPR NEWS RADIO[13]There are many options provided for the Dynamic PS parsing, delays etc. In the encoder's website, go to
RDS Configuration - Dynamic PS - Settings for Dynamic PS 1, Common Settings for Dynamic PS (see the picture)

For Radiotext only:
Code: [Select]

The [13] is a command meaning Enter. It is required by all encoders to terminate the ASCII text string. Most software inserts it automatically.
Posted by: Nemosity
« on: December 07, 2020, 08:01:56 pm »

OK, thank you.  What about the speed in the updating?  What could be causing such a lag in the display of the information getting to the P332 encoder? 

Here are some screen shots of ENCO automation's Padapult program we are using.  The "DPS=" Needs to be on the text when sending directly to the Nautel FM transmitters that are capable of RDS encoding, (NVLT, VS and GV versions).  However, I have two Nautels that are the NV versions and cannot do RDS encoding, requiring an external encoder. 
Posted by: Jan
« on: December 07, 2020, 06:50:34 pm »

You should simply remove everything what is beyond the text required. The encoder accepts text in all standard formats. But each software has different approach and not every software is well documented. If you're not sure, post the configuration screenshot here. Without seeing it, I can only guess. Or contact their support how to reset the software into sending standard text format.
Posted by: Nemosity
« on: December 07, 2020, 06:33:04 pm »

Ok, I’ve at least got it sending data, though it’s not updating as it should.  The display I had up this afternoon was from early this morning.  Also, what variable, if any, needs to be put in so that it does not display the DPS= in the display field? Or should I simply remove that tag from my automation info that is being sent?
Posted by: Jan
« on: December 05, 2020, 08:50:13 am »

You may fill any default PS (8-character long field for station name), that has no effect on anything else.

Correct prefix for the text being sent is however necessary. The most common prefixes are TEXT= for Radiotext and DPS1ENQ= for Dynamic PS. The Radiotext 1 or Dynamic PS 1 must be enabled on the encoder (it is enabled by default).

For RT+, the broadcast automation system must support X-Command format of the text or at least UECP MEC 24 or RTP command. Good systems already support that. If you're not sure, post here the padapult configuration screenshot.
Posted by: Nemosity
« on: December 04, 2020, 11:55:50 pm »

That worked like a charm to connect to my studio automation!  Thank you!
It was working with dynamic display until I tried removing the *RDS* out of the default PS field and removed "DPS=" off the text I was sending.  Now I can't seem to reverse it and get it working again; three steps forward, two steps back.
Posted by: Jan
« on: December 01, 2020, 09:47:41 pm »

Great, thank you. I'm already out of office for today so I'm not able to track how this happened but I can say that the story ends. What is certain is that the firmware version 2.2 has never been intended for P132/P332. It was written for the P164, before all these models were unified at the firmware level.

Current firmware version for entire family of RDS encoders is 2.2b which can be downloaded at

Once you apply this FW via serial port, reconfigure again the PORT3/PORT4 parameters and reset the device.
Posted by: Nemosity
« on: December 01, 2020, 09:24:48 pm »

Also, here is the serial number and mac of the unit I am working on today.

Serial number:   14095E92
MAC address:   0003941DA2C8
Socket status:   I/(-200,-200,-200,-200,-200,-200,-200,-200,-200,-200)
Posted by: Nemosity
« on: December 01, 2020, 09:23:21 pm »

Thank you for your prompt response, this has been quite frustrating.  Please see the response and information in red below:

You do not mention supplier of the units, MAC or order number so I cannot track the units. Please send me the complete listing from the web GUI, section Status - Version.   

 RDS encoder firmware version 2.2
Embedded website version 2.1a
Build 2018-10-05
Ethernet module firmware version ID811d17 20.6.2016
Bootblock version 0801 9.6.2009

Next, go to section Tools - Terminal, and type following commands there, each confirmed by Enter:
Code: [Select]
MEM 7D,6
MEM 7E,6
Copy and post the replies to us.

Here are the replies to the terminal commands Listed above:

15:20:12 Code: [Select]
15:20:13 Command not accepted
15:20:22 SETLAN
15:20:23 AT+iFD$AT+iWEBP=80$AT+iWPWD=*$AT+iRPG=1234$$AT+iGMTO=-5$AT+iDSTD=02.LSun.03;03.LSun.10$AT+iNTOD=1$
15:20:27 SETPORT3
15:20:28 OK
15:20:31 SETPORT4
15:20:32 AT+iLTCP:10001,1$
15:20:49 SETCTO
15:20:50 1,1
15:21:01 MEM 7D,6
15:21:02 FF
15:21:13 MEM 7E,6
15:21:14 FF
Posted by: Jan
« on: December 01, 2020, 06:44:01 pm »

This is a real mystery. We are very sorry that you have to solve this issue. From more than 5000 units sold this is a first report of that kind. The working web GUI is a proof that the unit can establish TCP connection without problems, because the web is still the server-client TCP communication. Thus there's no problem with the hardware, it is only software or configuration issue.

You do not mention supplier of the units, MAC or order number so I cannot track the units. Please send me the complete listing from the web GUI, section Status - Version.

Next, go to section Tools - Terminal, and type following commands there, each confirmed by Enter:
Code: [Select]
MEM 7D,6
MEM 7E,6
Copy and post the replies to us.
Posted by: Nemosity
« on: December 01, 2020, 04:43:41 pm »

I am at wits end here.  I can put a borrowed Innovonics 730 inline and it takes the data from my studio with no issues.  Yet, both Pira332's that we recently purchased are unable to connect through TCP/IP.  There is no network issue, I can ping the units at each site from the site computer.  I can pull up the web gui of each unit from outside the transmitter sites, and from the computer at each location.  Yet when using Magic RDS3 or Magic RDS4 I am unable to connect from the PC at each site through TCP/IP.  Serial connections work, web GUi's work, TCP/IP connection with the encoder set to be the server will simply not work.  These units are either defective, firmware was incorrectly loaded or there is a setting in them that is wrong, everything else has been tried.  The networks have been checked, rechecked, and checked again.  The fact that an Innovonics 730 works and connects without issue also shows the network and config is correct.

screen shots attached.  Both of these units, at two completely different sites exhibiting the same exact issue, hangs on connecting.
Posted by: Jan
« on: November 14, 2020, 08:46:53 am »

Of course not.

The problem is not in the Magic RDS nor in the encoder but somewhere around.

Possible causes:
  • The PC has multiple network adapters but primary adapter is not the one located in the network segment 192.168.0.x
    Go to Magic RDS - Tools - SNMP - Configuration - Enabled. You must see a message SNMP enabled @ 192.168.0.x:161
  • The communication is blocked by firewall. The Magic RDS unblock itself in the Windows Defender on installation but there may be other firewall installed. This is a common practice on broadcast PC.
  • The network router is not configured right or is bad. Reset it, replace it, after consultancy with IT specialist.
  • There's another conflict in the network. As we noted before, if DHCP function is enabled in your network, you should never assign the IP address manually on particular devices, but actually you did that. This may result in unexpected behavior.
  • If there was a specific requirement for configuration in your network in past, you should consult it with the man who made that.
Posted by: Nemosity
« on: November 13, 2020, 11:44:32 pm »

Do I need the full activation of Magic RDS 4 to make this connection?  When I click on Help and Licenses, I see it says Activated.  Just wondering if that could be the issue.  Everything else appears straight forward but refuses to connect.

I've reset everything to factory defaults, uninstalled and reinstalled Magic RDS 4 and it still just sits at "connecting". 

Does the RS232 need to be physically unplugged for the TCP/IP connection to work through Magic RDS 4?