Post reply

Message icon:

Unregistered users must pass a verification:

Please enter the number from the picture above which is showing FM broadcast antenna:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Jan
« on: October 16, 2012, 08:27:55 am »

There's probably SITE parameter set to a number different from 0 or 255.

If you don't want to use addressing via SEL command, use latest Magic RDS, select Options - Special - Assign unit address - Disable / Disable - OK.

In terminal this is:

If ADR returned is 255 and site returned is 3, now enter:

(For safety reasons the ADR and SITE cannot be changed if the unit is selected via 'ALL').

Posted by: joelwitkowski
« on: October 15, 2012, 10:22:53 pm »

Well, looking at the LED indicators proved to be very useful.  I guess there is good reason they are there!  Anyway, I found that the unit was "unselected" based on the flashing of LED1.  I am not sure precisely why this was a problem, when I queried the device it stated it was addressed at 255.  The SEL=ALL command seemed to remedy the issue.  Using it this way is not the least bit problematic for my applications.  Many thanks for the help!  It works!
Posted by: joelwitkowski
« on: October 03, 2012, 03:44:57 pm »

I did order the kit directly from you guys and I have set the baudrate appropriately for each given application.  I do also understand that the gender of the cable will in most cases suggest if a straight through or crossover is needed.  I will attempt to use the unit again in the near future paying closer attention to the LED lamps to see what I can determine.  Many thanks for the advice.  And yes, I did initialize the device with the RDS app.
Posted by: Jan
« on: September 28, 2012, 08:43:44 am »

As I understand, the issue is therefore not related to the dynamic data but to the fact that the device communicates only when it is connected to local port.

The PIRA32 allows communication on five different baudrates. Before placing it on the site you must set the baudrate that the communication channel actually uses. Otherwise the device can't reflect to incoming data.
The MagicRDS control software detects the baudrate automatically. This is the reason why it always works when connected to local port.
In MagicRDS choose Options - Change COM Port Speed and select the baudrate that is used in the channel to the remote site (as this baudrate is usually fixed). Then you may disconnect the device from local port and use it remotely.

Also don't forget that your model is probably equipped with male serial connector. Cable wiring with another device equipped with the same connector is 2-3, 3-2, 5-5 while cable wiring between male-female is 2-2, 3-3, 5-5. The encoder's LED indicates if there are at least some data (regardless of actual baudrate). If it indicates no data, the problem is in connection.

From your post it is not clear if your model is directly from us or it is a 3rd party product or self made unit. Sometimes people forget to initialize the device after assembling. That may result in seemingly unexpected behavior. In MagicRDS choose Options - Special - Initialize. Note that this operation clears all data in the encoder.
Posted by: joelwitkowski
« on: September 27, 2012, 09:13:25 pm »

I am having some issues getting this little (PIRA32) beast to do what I want it to do and I suspect I am missing some small detail and any help which can be offered to me would be helpful. 
Let me begin at the beginning, I bought this unit so we could have dynamic PAD data at one of our stations instead of simply the static message.  I can get the unit to preserve the settings and I can make it work, but I cannot get the PAD pushed to it.  I am missing something...somewhere...somehow. 

Originally I wanted to use it with a DG Storq system which was sending data only TO our remote transmitter site over the Moseley digital decoder data1 port.  I was able to change RDS records previously over this same one-way serial link with our old encoder so I know that SOMETHING gets through the data port.  Could not make that work. 

So, for testing used at one of our stations that has the transmitter and automation in the same place, cannot get PAD data sent there either, with UECP enabled, RT and DPS set to equal and using prefix/header DPS1=.   Will not work.

Then, I put the thing in no header mode and hooked it to the serial port on one of our satellite fed (an XDS tuner PAD port) stations.  I know the data is there, I can see it sent in hyperterminal if hooked directly to a PC.  I thought, surely this will work.  No go.  All the static RDS info that was programmed there is still there, but I get no dynamic data.

Then it occured to me that I actually assembled this thing.  Perhaps I did it wrong.  Is it possible or likely that the unit would program normally, accept changes, save changes, have PTY and PS work, and not permit anything else to work?

I basically am at a standstill here.  Any help that anyone can offer is useful.  I built the thing a while ago and never got it working the way I wanted so I put it up for a while.  Now, I have forgotten the specifics of what I have tried and what I have not tried. 

Thanks in advance.