Author Topic: Pira.cz 1W Portable FM Transmitter problems  (Read 27 times)

Poomex

  • Guest
Pira.cz 1W Portable FM Transmitter problems
« on: April 11, 2018, 09:06:22 pm »
Hi!
I have built the 1W FM transmitter from your site (http://pira.cz/entx3.htm). At first, I couldn't get the 2SC1971, co I replaced it with the RD06HVF1, without making any other modifications to the circuit.
When I turned the transmitter on, the PLL LED lit up and after adjusting the volume knobs I could transmit music from my computer for about a minute, after that it drowned in static. However, the 6 V / 0,1 A bulb wouldn't light up at all and the RD06HVF1 wouldn't even get warm, even though I set the transmitter to HI. I tried messing around with the controls, held down the PLL reset button (at least I think that's what it is) for about ten seconds and then *POOF*, the LED stopped working and there was no signal coming out.

So I started to replace parts, got my hands on some 2SC1971 to make the circuit exactly like in the instructions, and finally, I replaced the PIC microcontroller. The LED is now on, but I still get no FM signal, no matter what frequency I set and the bulb still has not even once turned on.

This is my first electronic circuit, so all the knowledge I have comes from building it and some youtube videos about the basics of electronics. I don't really know where to start troubleshooting  :-[. Am I supposed to calculate voltages in different parts of the circuit and then measure them? If so, how? Or is there some easier way?

Thanks a bunch in advance for helping me out. It would be greatly appreciated  :)