Author Topic: RDS encoder module newbie questions  (Read 2155 times)

w0kie

  • Newbie
  • *
  • Posts: 10
RDS encoder module newbie questions
« on: July 14, 2018, 11:34:55 pm »
1.  Does the encoder module have a power on led?
2.  In MagicRDS I get "connected" in Preferences General using 2400 baud, both on com 1 and com 3.   When I go to step 1 of 9 in the Settings Wizard the connection test fails using the null cable supplied by Pira.  Where do you suggest I begin my trouble shooting?

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #1 on: July 14, 2018, 11:48:57 pm »
If you don't see any LED indication, the module is not powered, thus any communication attempt is unsuccessful.

BTW the topic name is potentially misleading because the P232 module is actually not intended for newbies. We offer complete product for that purpose, incl. proven accessories like power supply or USB to RS-232 adapter.

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #2 on: July 15, 2018, 12:58:27 am »
Is the power LED a red plastic nodule to the rear of the serial port?

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #3 on: July 15, 2018, 08:13:33 am »
Two LEDs were supplied with the module. Connect them to marked positions on the board: LED1 and LED2.

The red part is a fuse, not a LED indicator.

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #4 on: July 17, 2018, 05:56:27 pm »
Using alternative and proven 12 V power brick.  Module white LED1 slowly flashing.  Still no successful connection to module using Pira wizard via "low-cost Chinese adapter based on Prolific chip."  Have now ordered an FTDI adapter.  I suggest that Pira make a warning about the Prolific serial adapter chip in the quick installation guide.

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #5 on: July 19, 2018, 10:28:52 pm »
Now have installed USB 2.0 to RS232 Teragrand FTDI adapter.  Then installed latest Teragrand Win10 drivers.  Rebooted PC, hooked up Pira null cable from USB adapter to Pira module.  Magic RDS Options/Preferences works perfectly with connection type RS232.  Win 10 says FTDI adapter is working perfectly.  BUT Magic RDS wizard step 1 Test says "no response from the RDS encoder."  Encoder LED2 briefly lights up at module power up and then LED1 flashes in a steady pattern.  Please advise.

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #6 on: July 19, 2018, 11:45:01 pm »
This should be entirely seamless.

There are several COM ports in your PC. Only one of them is the USB adapter connected to the RDS encoder. Only that COM port will work. Check this in the Device manager. Make sure you've selected that COM port in the Magic RDS Preferences, not some of others (which could be a bluetooth, IrDA, modem etc.).

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #7 on: July 20, 2018, 12:35:51 am »
Done all of that.  Epic fail on computer number 2 in trying to communicate with pira approved usb to rs232 dongle.  Module does work as I can see *rds* appearing on car radio display.  I did note that deviation in factory setting increased from 75 to 95.  Humm.

Now onto computer number 3.  Could the problem be a defective usb/rs232 dongle or defective Pira null cable or (gasp) a defective Pira module or finally a defective Magic RDS?

Computer number 3 may or may not point to the problem.  In the meantime is the module returnable for refund or for upgrade?

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #8 on: July 20, 2018, 10:28:10 pm »
The product was found to be functional before packing. As a manufacturer, we cover the product by warranty but we are not able to provide more services related to installation and setup of this product which is not designed for end users. Please contact us by email for return and refund.

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #9 on: July 21, 2018, 11:31:01 pm »
Computer number 3 results according to a friend who ran the communication test:  "When I turned off Bidirectional and Auto speed detect it no longer gives errors when testing."

Will his serial settings compromise the use of the rds module?

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #10 on: July 22, 2018, 11:32:38 pm »
When you turn off the Bidirectional option, you always get no error. Also with no encoder connected.

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #11 on: July 23, 2018, 03:58:49 pm »
Does the bidirectional option need to be enabled in order to receive the now playing data from the automation software (station playlist)?

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #12 on: July 23, 2018, 07:29:09 pm »
It does not need to be enabled. But you have no feedback from the unit, that is you have no confirmation if the unit receives the data. So you have to check it on the receiver. Does it update?

w0kie

  • Newbie
  • *
  • Posts: 10
Re: RDS encoder module newbie questions
« Reply #13 on: July 25, 2018, 01:59:43 am »
Replaced the FTDI adapter with a new dual port serial card in our production XP machine.  Options/Preferences appeared to be properly working with the new serial card but still could not get bidirectional serial communication to occur, nor could we get the module to save one directional data from Magic RDS.  The module seem to light the LEDs as expected and send the word *RDS* to a car radio display. 

Jan

  • Hero Member
  • *****
  • Posts: 559
Re: RDS encoder module newbie questions
« Reply #14 on: July 25, 2018, 07:41:56 am »
Please follow my post from July 20th.

From previous posts, it appears that the device was not used in accordance with the instructions (improper power supply at least). From that point we cannot guarantee function and I can not help as I wish because I don't know real status of the device, if there was some electrical modification made etc.