Author Topic: Stuck in No Header Mode  (Read 3387 times)

forksb

  • Newbie
  • *
  • Posts: 3
Stuck in No Header Mode
« on: July 19, 2014, 01:42:48 am »
Our PIRA32 is stuck in No Header Mode. We followed the procedure from the manual, connected via Hyper Terminal and pushed ESC ESC ESC ENTER on the keyboard. Nothing appears in the Hyper Terminal window and the PIRA32 remains in No Header Mode.

Jan

  • Hero Member
  • *****
  • Posts: 622
Re: Stuck in No Header Mode
« Reply #1 on: July 19, 2014, 09:00:56 am »
The sequence is right, however the baudrate set in terminal differs from the encoder's baudrate. Set right baudrate in the terminal.
Other possible reason is that the encoder operates in standard mode but you've enabled the addressing feature by adjusting its address and the unit is unselected.
Your encoder has a LCD, everything mentioned above is indicated there.

forksb

  • Newbie
  • *
  • Posts: 3
Re: Stuck in No Header Mode
« Reply #2 on: July 20, 2014, 12:06:09 am »
The Baud rate is 2400 on both, and the PIRA32 LCD displays the address as 0,0 *
Is there a jumper, button or any other means of returning the hardware unit to factory defaults?

Jan

  • Hero Member
  • *****
  • Posts: 622
Re: Stuck in No Header Mode
« Reply #3 on: July 20, 2014, 09:46:14 am »
Yes, in the Magic RDS control software, select correct speed in Options - Preferences, then select Options - Special - Switch off no header mode.

forksb

  • Newbie
  • *
  • Posts: 3
Re: Stuck in No Header Mode
« Reply #4 on: July 21, 2014, 09:43:57 pm »
Thank You, that worked.

Jan

  • Hero Member
  • *****
  • Posts: 622
Re: Stuck in No Header Mode
« Reply #5 on: July 21, 2014, 10:01:19 pm »
The interesting thing is that choosing this option makes exactly the same: ESC ESC ESC Enter. I've searched via Google for more information, it seems that the Windows Hyper Terminal sometimes does not send ESC character although the user presses this key. There are unfortunately too many bugs in the Hyper Terminal...