Post reply

Message icon:

Unregistered users must pass a verification:

Please enter the number from the picture above which is showing FM broadcast antenna:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: davidbiz
« on: April 06, 2024, 11:50:43 pm »

Thank you! Updated ST to the latest version and it seems to work now. Thanks again.
Posted by: Jan
« on: April 06, 2024, 10:02:38 pm »

Thanks for your post which makes it completely clear.

The reason for such behaviour is that there's a second RT+ encoder running in the ST. This RT+ encoder sends blank data. On the receiver side that results in periodical switching between correct RT+ from the Magic RDS and blank RT+ from the ST.

You need to reset the ST or disable its internal RT+ module.

The Magic RDS periodically sends only

that means:
ODA AID group 3A assigning group type 11A to the RT+
and RT+ data in the group 11A.

The UECP buffer mode for such data is "flush and forget", the Magic RDS does not set any permanent transmission for such data, so even changing the Magic RDS settings in the RT+ extension cannot result in such behaviour.
Posted by: davidbiz
« on: April 06, 2024, 09:36:02 pm »

Thnx for your feedback. Before we were using Magic RDS 3.8 with ASCII mode and RT+ worked, but with new version I cannot even get radiotext through lite ASCII, so that is why we are using Generic UECP. Also We have enabled RT+ Encode in Software Extensions - 11A. Even if I try with others it seems that it makes no difference.

Anyway, sending communication monitor data and recording from RDS Spy.

Posted by: Jan
« on: April 06, 2024, 12:18:01 pm »

UECP has no explicit support for the RT+ so you either need a RDS encoder with X-Command support or enable the RT+ UECP extension, which is a PC software-based RT+ encoder.

The RT+ UECP extension works correctly with encoders which comply with UECP specification.

To see what's wrong, I would need a sample record from the RDS Spy (at least 1 minute) and a sample listing from the Magic RDS - Overview - Communication Monitor.
Posted by: davidbiz
« on: April 06, 2024, 12:38:39 am »


I just bought 2 instances of Magic RDS 4 to use it on FM, but I cannot get RT+ right. We have connection through TCP/IP and UECP to Stereo Tool 10.21 standalone app. Radiotext goes through, but if I want to enable RT+ I must enable software extension, but then RT+ keeps appearing and dissappearing. RT+ is active only for second or two. I tried much everything (different groups, sequence in ST).

Can you help please?