Author Topic: Initial Configuration P332 wont connect over TCP/IP  (Read 71 times)

WB5MGR

  • Guest
Initial Configuration P332 wont connect over TCP/IP
« on: March 28, 2018, 06:46:24 pm »
Unit won't connect over included software, nor will it accept a connection from Telnet of SSH when connected by Ethernet using DHCP. It did take a valid address and does respond to a ping, but that is as far as it will go. Unit is fresh out of box and this is my first one to ever set up so I just need a point in the right direction.

Thanks!

Jan

  • Sr. Member
  • ****
  • Posts: 460
Re: Initial Configuration P332 wont connect over TCP/IP
« Reply #1 on: March 28, 2018, 08:27:21 pm »
Factory default configuration contains no opened TCP port for communication, except the embedded website.

Citation from the document P332 RDS Encoder - Quick Installation Guide (p332inst.pdf):

Quote
4.1 Establishing a First Communication with the RDS Encoder

The RDS encoder should be configured via local port (port 1) before first use. Alternatively, the configuration can be made using the embedded website.

For details see section 4 of the same document.

  • If you use local port (Port 1) for the configuration:

    Run the Magic RDS software.
    Open the Preferences (Options - Preferences) and set up the connection parameters. Choose the Serial RS232/USB connection type and select the COM port the RDS encoder is connected to. If the RDS encoder is connected via USB and was recognized correctly in Windows, you may find/change the COM port number in Windows Control Panels - System - Hardware - Device Manager or simply click on the List button.
    Close the Preferences. You should see "Connected" or "Opened" in the status bar.
    Open the Device Setup dialogue box (RDS Encoder – Device Setup).
    Enable Port 3 or Port 4, tick the TCP protocol and Server option. Note the port number.
    Confirm by Store button. Reset the RDS encoder.

  • If you use embedded website for the configuration:

    Navigate to LAN Settings.
    Enable Port 3 or Port 4, tick the TCP protocol and Server option. Note the port number.
    Confirm by Update button. Reset the RDS encoder.

Note that SSH is not supported by the device.